WHAT a nightmare.

for registered members' test posting and requests for new features in these discussions
Locked
llizard (aka ejm)
Administrator
Posts: 535
Joined: Wed 06 Oct, 2004 10:51 pm

WHAT a nightmare.

Post by llizard (aka ejm) »

I have just reinstalled the forum entirely.

I think things are running correctly again... I had to physically remove all the forum files from the server. Last week, we got a notice that there was a phpBB Security Exploit that affected all phpBBs that were lower than version 2.0.16.

I thought I was okay because mine was at 2.0.19. And then on Friday, I got an email from my webhost saying that my forum had been compromised and telling me I MUST upgrade....

What I hadn't realized was that a couple of modifications I had made were still at 2.0.11, not to mention that this forum does not use the default theme template "SubSilver". I use "Classic". Some of those files were at 2.0.16 - and possibly lower. (I maintain another forum on another server - that one uses "SubSilver" and should be fine.)

In the process of doing all this uninstalling and reinstalling, I do believe that I made every mistake it was possible to make. Hey! Do I get a medal for being best at mistake making? :lalala:
I hardly ever use this username any more. I usually use "ejm"
Barbara
registered
Posts: 351
Joined: Wed 13 Oct, 2004 5:17 pm

Re: WHAT a nightmare.

Post by Barbara »

llizard wrote:I have just reinstalled the forum entirely.
Hurray! :bravo:
llizard wrote:In the process of doing all this uninstalling and reinstalling, I do believe that I made every mistake it was possible to make. Hey! Do I get a medal for being best at mistake making? :lalala:
Sounds like an horrid experience.

:ohoh:
llizard (aka ejm)
Administrator
Posts: 535
Joined: Wed 06 Oct, 2004 10:51 pm

Re: WHAT a nightmare.

Post by llizard (aka ejm) »

blm wrote:
llizard wrote:In the process of doing all this uninstalling and reinstalling, I do believe that I made every mistake it was possible to make. Hey! Do I get a medal for being best at mistake making? :lalala:
Sounds like an horrid experience.

:ohoh:
It was quite horrid. Especially at one point when I realized that I had changed almost all the code in about 10 of the WRONG files and had to start ALL over :arrow: does anyone know how to remove angry spit from the monitor and keyboard? :stomp:
I hardly ever use this username any more. I usually use "ejm"
MrsBrown
registered
Posts: 303
Joined: Wed 13 Oct, 2004 10:02 pm

Post by MrsBrown »

I was looking at the slogans and I happen to know that Nicky the Black Dog changed her slogan but it doesn't appear in her messages. Didn't the slogans used to appear? Is it something to do with the reinstalling (which I think you did brilliantly except for this one very very small point). :ah: :ah: :ah:
llizard (aka ejm)
Administrator
Posts: 535
Joined: Wed 06 Oct, 2004 10:51 pm

Post by llizard (aka ejm) »

MrsBrown wrote:I was looking at the slogans and I happen to know that Nicky the Black Dog changed her slogan but it doesn't appear in her messages. Didn't the slogans used to appear?

Eeeek!!! :stomp: You're right! The slogans aren't showing up here at all. Thank you for pointing it out, MrsBrown.

I didn't notice. I'll have to go ferretting(sp??) through my old files to see what I did to make them appear.


edit a few moments later:
MrsBrown wrote:except for this one very very small point).
:ohoh: small point?! I think the slogan on the sidebar is one of the most important details. I can't believe that I didn't notice that it was missing! WHAT a blunder.

Luckily, it didn't take me too long to find the missing coding to insert :jump:
I hardly ever use this username any more. I usually use "ejm"
llizard (aka ejm)
Administrator
Posts: 535
Joined: Wed 06 Oct, 2004 10:51 pm

And another nightmare is over...

Post by llizard (aka ejm) »

And another nightmare is over... well, until the next upgrade, anyway. :stomp:

I have just upgraded the forum to the latest release. As far as I can tell, everything is now ( :ohoh: or not* :ohoh: ) working as it was before.

* I know. The colour changer is NOT working. :stinks: I'll try to fix it soon... when I add the dog emoticon... or something :lalala:
I hardly ever use this username any more. I usually use "ejm"
Locked